0

I have a USB device from a vendor (TRENDnet) that has the exact same chipset as a QNAP device with an available firmware patching tool.

It's my belief that this firmware patching tool should work perfectly fine with my TRENDnet device.

However, when I run the firmware patching tool, it reports that it cannot find a suitable device and exits.

I believe the firmware patching tool is looking for specific USB VIDs and PIDs to detect valid USB devices. I've extracted from the drivers that these are the valid VID/PID combinations.

VID_2ECA - PID_C101
VID_2ECA - PID_C102
VID_0B95 - PID_2790
VID_0B95 - PID_2791
VID_1C04 - PID_0015
VID_1C04 - PID_0016

I would like to see if it's possible to inject additional PID/VID values into the tool to allow my device to be detected and have the firmware upgraded.

I've tried searching for the various VID/PID combos in a hex editor to no avail, and have also tried to decompile the app using IDA Free with no success (mainly because I have no idea what I am doing).

Can someone either look at the file or offer some advice of what to do look for/try next?

The firmware patching tool can be downloaded from this link.

The tool is named aqusbupdate.exe and it reads in QNAP_QNA-UC5G1T_FW_3.1.6.bin when passed in as an argument.

1 Answer 1

1

I've made a quick research - if you're getting [!] No devices found prompt this is likely due to the updater getting no adapter results with the below WQL query:

aqusbupdate.exe's adapter WQL query

I guess checking if you have Aq_UsbNetAdapter WMI objects available would be a starting point.

2
  • Can I ask how you were able to convert the .exe to this code view?
    – Geruta
    Jun 9, 2023 at 12:29
  • This is 32-bit IDA Pro's pseudocode view, IDA Free should have the decompiler available as SaaS; decompile the file, after IDA finishes the analysis double-click sub_41D3D0 function and press F5 to access the decompiled pseudocode view
    – mimak
    Jun 9, 2023 at 13:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.