With the release of IDA 7.0 Freeware, I've been wanting to open some of my academic projects I've been doing with IDA 5 in the new version.

However, the database format has changed. I have a set of .idb files which will not be opened by IDA 7.

What I have tried so far:

  • Opening the file directly in IDA as recommended in the manual. It's not listed as an option in the open menu, and when forced, it says it can't disassemble the file.
  • Rename the .idb file to .id0. It first reports that the file is not closed, asking to repair it. If I say Yes, it reports bTree error: bad B-tree header.
  • Rename the .idb file to .i64. It shows Please use 32-bit version of IDA to open <file>. There is no 32-bit version of IDA 7 Freeware.

1 Answer 1


Have you tried using the IDC importing procedure? It's also listed in the manual (https://www.hex-rays.com/products/ida/support/idadoc/444.shtml). Basically:

  1. Export from IDA old to .idc (this will generate an IDC file)
  2. Run new IDA with switch -x with your old IDB database (From my experience, this just opens IDA and autoanalyzes everything again, I'm not sure if that's the expected behavior)
  3. Execute the IDC file with IDA new (This is supposed to apply all manual work you've done in your old IDB database and apply it to the new database).

That said, I haven't had any luck getting this to work, but it's supposed to, so maybe you'll have better luck than me, please report back if you have any :).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.