3

i want to do kernel debugging on my vm from another vm.

My setup is pretty simple,

Debugged - VM: Windows XP SP3 x32 (To be debugged)

Debugger - VM: Windows 7 SP1 x64 (With Windbg installed - the Debugger)

the pipe configuration is pretty simple as well.. both ends should be set as The other end is a virtual machine, and on the XP VM i set the pipe as This end is the server and on the Win7 vm i set This end is the client. Im using Vmware Workstation 10.0.3 btw..

I know i did setup my XP vm correctly because i can debug it from the host easily - configuring The other end is an application and connecting it with Windbg from my host computer (Win7 x64) and its working properly. So i know there is no problem with my Win-XP setup

But doing the same thing from the other vm, nothing happens. I looked through the internet and i even followed tutorials that explained exactly what i already did. I have no idea what i'm missing and i feel pretty helpless so i came asking here.

Anyone got any ideas what is the problem with my setup?

15
  • Are all your settings the same as described in ndis.com/ndis-debugging/virtual/vmwaresetup.htm ? – Jason Geffner Nov 20 '15 at 17:32
  • @JasonGeffner, It does look a little different than my setup, yet its still not working. The difference is (Between what i thought is correct): They put on the Debugged vm The other end is an application when the other side is a VM that is supposed to debug it. Also on the windbg, the pipe name they use is \\.\com1 instead of \\.\pipe\com_1 which is what i did. Nonetheless its still not working even with their setup – 0xAK Nov 20 '15 at 17:54
  • As per pubs.vmware.com/workstation-10/topic/com.vmware.ws.using.doc/…, are you sure the serial port is connected in both VMs? – Jason Geffner Nov 20 '15 at 17:58
  • 1
    @JasonGeffner, communities.vmware.com/message/2557171#2557171 I gave it a try.. lets see if ill get any luck there – 0xAK Nov 20 '15 at 18:34
  • 1
    Since you are using VMWare Workstation, I would recommend the use of VirtualKD. It is really easy to set up, and is extremely fast. – tmr232 Nov 20 '15 at 20:27
3

Fixed the problem.. On the windbg client, uncheck the 'Reconnect' and 'Pipe' checkboxes on the COM tab - then it will connect to the debugger.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.