7

Environment:

  • Host: Win7 SP1 x64: VMWare Workstation 9.02, VirtualKD, IDA Pro 6.4.13 (x64) and WinDbg
  • Guest: Win7 SP1 x64

I have VirtualKD setup correctly in my guest and host. I say this because attaching WinDbg to the guest VM through VirtualKD works flawlessly.

But when I try to connect IDA Pro's WinDbg interface using instruction on this page, IDA keeps throwing the following error:

Windbg: using debugging tools from '<PATH>'
Connecting to debugger server with 'com:port=\\.\pipe\kd_Win7x64_SP1,pipe'
Connect failed: The server is currently disabled.

VirtualKD's vmmon is running on the host and shows the following:vmmon UI

UPDATE: Turns out, It's a problem with IDA 6.4. I happened to have IDA 6.3 installed on my machine too. That worked with no issues. Has anyone used IDA6.4 for live kernel debugging? Can someone please tell me how I can correct this issue in IDA 6.4?

  • welcome to RE.SE. Are you connected with WinDbg while you try to connect with IDA? – 0xC0000022L Apr 20 '13 at 6:21
  • No I'm not :) No other debugger is connected to the target at present – Lelouch Lamperouge Apr 20 '13 at 9:08
  • 1
    I would strongly recommend using official support channels (i.e. email) for such localized IDA issues. – Igor Skochinsky Apr 22 '13 at 15:04
  • Somehow that thought never struck me. Thanks! – Lelouch Lamperouge Apr 23 '13 at 1:14
6

I had the same problem at first when trying to connect IDAPro to windbg. What I did was the following:

  1. Manually edit the ida.cfg file located inside .\IDA 6.4\cfg\ directory.
  2. Change the DBGTOOLS path with WinDbg tools directory. For example, to:

    DBGTOOLS = "C:\\Program Files (x86)\\Windows Kits\\8.0\\Debuggers\\x86\\";
    
  • Just to add, it should be double backslashed, like in C programming. And make sure you selected Kernel Debugging in Debugger->Debug Options->Specific Debug Options – gelodelrosario Jul 10 '13 at 6:57
  • Also make sure that you have the 32-bit version of the debugger tools installed - the package is WinSDKDebugToolsRedist_x86 but MS won't install it when you install the debugging tools if you are on a 64-bit system. – cwd Jun 15 '15 at 5:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.