Questions tagged [libc]

C standard library for the C programming language as specified in the C specification (ANSI C, C99, C11, ...).

9 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
2 votes
0 answers

How to get the address of a glibc private symbol at runtime programmatically?

I am trying to get the address of a private function in GLIBC. For instance - the function __run_prefork_handlers(). I have done it with gdb, using info symbol __run_prefork_handlers and info address ...
joepol's user avatar
  • 121
1 vote
0 answers

problem with LD_PRELOAD

Hell0!!! I try ld_preload by pwntools and take it... How can I fix this problem???
K05t1K_RWX's user avatar
1 vote
0 answers

Locating Exit/Abort Functions from Static Analysis

Similar to this question, I'm interested in locating exit and abort style functions in a firmware - any function call that in fact terminates the execution, by statically analyzing the firmware. My ...
macro_controller's user avatar
1 vote
0 answers

How can a segfault happen during the libc exit call on Linux?

I'm relatively new to reverse engineering, and I've decided to practise using the challenges from Currently, I am working on the "Silver Bullet" challenge. While testing, I have noticed ...
correcthrsbatterystpl's user avatar
0 votes
0 answers

Why can't I resolve the 'system' dynamic addresss in ret_2_libc exploit?

First and foremost, I am a noob pwner. The problem at hand is from > pwn101 > pwn109. A simple ret_2_libc in which you exploit a simple buffer overflow, leak the addresses of gets()...
Christian Sanchez's user avatar
0 votes
0 answers

Dynamically linked busibox won't work

I am hacking an ARM-based device that is coming with a lightweight busybox: [/mnt/sdcard/busybox]## busybox BusyBox v1.24.1 (2017-09-29 00:55:28 PDT) multi-call binary. BusyBox is copyrighted by many ...
dotvav's user avatar
  • 131
0 votes
0 answers

system doesn't invoke /bin/sh

I am learning libc shellcode attacks and trying to execute /bin/sh from system I can execute other commands from system like whoami and ls -a but can not run /bin/sh the following works string = b&...
Devharsh Trivedi's user avatar
0 votes
0 answers

exploiting a binary using ret2libc

I ran into this binary at a CTF : I first tried to exploit it and get a shell using ret2libc technique, however I didn't ...
aguilbau's user avatar
0 votes
0 answers

dlmalloc free pointers

I was looking at the implementation of "free" in my current dlmalloc(both the source and the disassembly). However, I could not find the code section the inserts the FD and BK into free chunks. What ...
user avatar