2

I have spent some time reverse engineering a QNX 6.5.0 based system. I am pretty new to the Linux (Ubuntu) world and definitely new to QNX, Qemu, and embedded systems.

Since the hardware is fairly closed, the closest I could use is a Beagleboard-XM. Since I didn't want to purchase one, I decided to use Qemu. I have set it all up using the Linaro builds, etc. I have a system booting.

My issue is that I cannot, for the life of me, get the emulated QNX system to show a USB drive. I am using Ubuntu 14.04 LTS and am booting from an SD card. I don't card if I can actually load a USB drive, but it seems like the simplest solution to be able to get files off the QNX system. I have tried quite a bit. I am unable to get networking up and running and am unable to get QNX to recognize any devices.

Here is my working Qemu command line (version 1.7.0 (qemu-linaro 2014.01))

sudo qemu-system-arm -M beaglexm -m 512 -serial stdio \
                     -nographic -monitor pty -usb -sd /dev/mmcblk0

I have tried tons of command lines with -device, -drive, etc, etc. For example.

Nothing. One thing to note is that I have attempted to use the EHCI bus but am unable to get that working because I keep getting a

qemu-system-arm: -device usb-ehci,id=ehci: No 'PCI' bus found for device 'usb-ehci'

using the command line

sudo qemu-system-arm -M beaglexm -m 512 -serial stdio \
                     -nographic -monitor pty -usb -sd /dev/sdd \
                     -drive if=none,id=usbstick,file=/dev/sdb1 \
                     -device usb-ehci,id=ehci \
                     -device usb-storage,bus=ehci.0,drive=usbstick

Also, the emulated system tries to load an mmcsd driver and is looking for a raw /dev/mmc0. I have been unable to figure out how to get my SD card (or any other device) to show up with that mount name.

Any suggestions for being able to get files off the emulated system? I know that the system can use these two specific USB to ethernet adapters, but I don't have one. Maybe I could simulate one of those? My attempts at setting up a fake USB to serial connection also have failed. Basically, anything that requires USB support I am unable to get working.

This is what shows on the emulated QNX system when I query the usb host.

USB 0 (OMAP3530) v1.10, v1.01 DDK, v1.01 HCD
USB 1 (EHCI) v1.10, v1.01 DDK, v1.01 HCD

Any help would be greatly appreciated!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.