1

I was trying out a basic ARM crackme here. Upon running it on my Raspberry pi, it segfaults without giving me any warning. Moreover, I'm unable to set breakpoints anywhere(even on the entry point). Is there some gdb/ARM quirk that I should be aware of? This has happened on an earlier occasion too with another CTF challenge.

I do get the feeling that my questions is incomplete -- however, I'm not sure what additional information I could provide to help diagnose the problem. If you could let me know what additional information is required, I could update the question with that.

Some output :-

$ file arm_crack1
arm_crack1: ELF 32-bit LSB executable, ARM, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.16, BuildID[sha1]=0xbb39a930c55e6d62c7cc083bb94567adcfe5cc3b, stripped
$ ldd arm_crack1
    not a dynamic executable
  • Could you also include a ldd dump? Might be interesting to see how everything gets linked together on the target system. I haven't tried taking a look at the binary to see if there is any dependencies. If it doesn't depend on any libraries it's probably doing syscalls directly which can change between kernel versions. – Peter Andersson Jul 20 '14 at 15:26
  • @PeterAndersson Thanks, I've made an edit – user1743 Jul 20 '14 at 15:57
  • have you tried running strace on it? What kernel version are you running on the RPi? – Peter Andersson Jul 20 '14 at 16:18

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.