0

I'm trying to reverse an apk but there is a strange thing that happens, probably something new for me, basically if I decompile only the resources (not dex files) and recompile it zipalign/sign, the app installed works fine.

If I decompile also or only the sources (dex files), recompile it then zipalign/sign the app remain stuck on splash screen or sometimes crash going to background.

NO error messages from Android (crash dialog), NO usefull logs from logcat (I tried also making app debuggable and doing some trials), AFAIK NO signature verification methods or anti-tampering mechanism (I researched and added breakpoint on PackageManager methods, looking at some pattern for those mechanism and so on....), I was trying to look also the .so but I'm not so good at going through them (I don't have a good "starting point" to look at it).

Then, I'm not able to understand what is happening. When I decompile sources, there is some poorly recompilation that I made? I tried everything, I'm using latest version of apktool (2.9.1) and so on...

Just this, the decompilation / recompilation of dex files break the app (not loading the main activity) without any usefull stack trace.

I will appreciate a lot your help, thanks in advance!

(Tell me eventually everything you need, logs, bugreports from adb, informations, etc...)

1
  • In such cases it is better to use the original APK and run it on an rooted phone and then trace execution of certain functions using e.g. frida-trace.
    – Robert
    Dec 24, 2023 at 11:59

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.