2

When I try to debug one of hackadayu exercises (or any other file) using "debug c1 in dbgeng locally via GADP" I get following errors:

    Launch failed for {args=/C:/Users/abc/Desktop/ghidra/hackaday-u-master/session-one/exercises/c1}
ghidra.dbg.error.DebuggerUserException: Launch failed for {args=/C:/Users/abc/Desktop/ghidra/hackaday-u-master/session-one/exercises/c1}
    at ghidra.dbg.gadp.client.GadpClient.checkError(GadpClient.java:163)
    at ghidra.dbg.gadp.client.GadpClient.lambda$sendChecked$2(GadpClient.java:358)
    at java.base/java.util.concurrent.CompletableFuture$UniApply.tryFire(CompletableFuture.java:642)
    at java.base/java.util.concurrent.CompletableFuture.postComplete(CompletableFuture.java:506)
    at java.base/java.util.concurrent.CompletableFuture.complete(CompletableFuture.java:2073)
    at ghidra.async.AsyncPairingCache.fulfill(AsyncPairingCache.java:166)
    at ghidra.dbg.gadp.client.GadpClient.lambda$receiveLoop$4(GadpClient.java:378)
    at java.base/java.util.concurrent.CompletableFuture$AsyncRun.run(CompletableFuture.java:1736)
    at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
    at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
    at java.base/java.lang.Thread.run(Thread.java:829)

I tried running it with admin right etc. without success.

1 Answer 1

2

I've just downloaded the "c1" exercise from https://github.com/wrongbaud/hackaday-u.

This is a linux elf:

> file c1
c1: ELF 64-bit LSB pie executable, x86-64, version 1 (SYSV), dynamically linked, interpreter /lib64/ld-linux-x86-64.so.2, for GNU/Linux 3.2.0, BuildID[sha1]=d9462be5061532875d1ea68aab66366a42f87d6c, not stripped

You need a Linux OS (a VM will works too) in order to debug it.

You are clearly trying to run it on Windows (C:/Users/abc/Desktop/ghidra/hackaday...)

2
  • thank you, it worked. do you have an idea on how to debug ARM code with ghidra? I read that I need some machine that runs ARM and can run ghidra + debugger, which one could I use?
    – julfl9
    Apr 6 at 14:26
  • Hi, yes you need an arm based cpu (real or emulated). You can use Qemu to achieve that. Regarding the debugger, you haven't even told me what is the guest OS you want to run on that machine, but if gdb is available, then yes. Anyway this is a total different topic that can't be discussed in a "comment". Also, please accept my answer if I helped you. Apr 8 at 8:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.