0

I have a python dir within IDA 6.8 folder with idaapi.py, idautils.py, and idc.py. IDA doesn't seem to pick the Python scripting by default.

How do I enable it?

4
  • 1
    IDA 6.8 was released in 2014 -- 8 years ago. Have you considered upgrading to a more recent version? Mar 14 at 21:05
  • Are you talking about Python 2 or 3? The capability to use Python 3 was introduced in one of the 7.x versions (could be 7.2 not sure about this).
    – Robert
    Mar 14 at 22:02
  • @Robert For 6.8 it uses Python 2.7. It even has an installer for it with the distribution. Not helping to setting it up though...
    – Irbis77
    Mar 15 at 7:58
  • @RolfRolles I just didn't want to disturb my current setup. Since I was doing it over the years and I am not sure I needed any new features until now, which is not that new either as Python support was there for a while.
    – Irbis77
    Mar 15 at 8:01

1 Answer 1

1

Fixed it with the help of this page

At the end of the day it was

  1. pointing to python 3.8 installation instead of Python 2.7 although both were installed on the machine

  2. python27.dll was not in the package I've used to install Python 2.7. Had to reinstall it

  3. had to remove PYTHONPATH and PYTHONHOME completely and leave only PATH pointing to Python 2.7 installation

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.