-2

I'm having trouble finding the key and sign to decrypt my program. I have tried everything like IDA but to no avail Link apk file: https://drive.google.com/file/d/1YNNcsFXxJ11ciVUSzxwAUukU06DWUws0/view?usp=sharing

I found the signature through the signature in my luac file enter image description here

I think the red part will be the key word to search for the key in my libcocos2dlua.so file. Then I used IDA pro to find the key

enter image description here

I think the area circled in red above will be the key. I use some software to decrypt luac files through key and signature.

After decoding I get a file like this: enter image description here

I noticed that the file is only decoding some characters, the rest is not. I don't know how to check if my key or signature is correct

3
  • Sorry for my ignorance. Oct 15 at 4:40
  • I will edit the post Oct 15 at 4:42
  • In general if a cryptographic encryption method is used and you are using the wrong key you will get only random garbage, so expect the key to be correct. As you already mentioned you are getting a luac file which contains lua byte code (not source code). Have you tried to decompile the luac file?
    – Robert
    Oct 15 at 12:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.