1

I am trying to root an old Linux device I have, it uses the CFE bootloader by Broadcom. I know the username and the password, but something really strange happens when I try to login.

I get a prompt for username and I can type it in fine, however, the prompt for the password allows me to enter only the A-D0-9 characters and the space (capitals only).

If I change the kernel boot arguments so that init=/bin/sh, I get a bash shell, but I have the same issue. I can type in only the A-D0-9 characters and the space.

The strange thing is, I can enter the username fine and interact with the CFE Bootloader CLI interface perfectly fine.

It seems to me that the Linux kernel might be doing something weird with maybe the locale? Any ideas what I can check?

I have tried two different USB → UART TTL devices and I have the same issue with both.

Edit: I've also tried resetting the USB → UART TTL Adapter in between entering the username and the password or interacting with the bash shell. So it definitely has something to do with kernel state. Possibly an anti-tamper / protection mechanism??

EDIT: Looks like keymap.xml is completely empty. Could this be the cause?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.