1

I've been trying to debug a binary file in radare2 but it throws me this error.

$ r2 -d bin                      
Killing child process 1688 due to an error
Killing child process 1689 due to an error
[w] Cannot open 'dbg://./bin' for writing.

So I ran it without the -d parameter but I'm unable to execute the program by dc as the error below is shown

[0x00000610]> dc
Cannot continue, run ood?

I tried running ood but following prompt is received

[0x00000610]> ood
Killing child process 1711 due to an error
Killing child process 1712 due to an error
r_core_file_reopen: Cannot reopen file: dbg:///home/kali/Downloads/bin  with perms 0x7, attempting to open read-only.

Is this the problem with the binary or am I doing something wrong? Some help is appreciated.

2
  • 2
    what is this bin file? did you set it as an executable chmod +x bin? May 18 at 8:06
  • No I didn't, I'm an absolute beginner so thanks for pointing that to me
    – Nimrod
    May 18 at 9:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.