I added read/write trace to a program. I was able to record the trace with IDA for the first time.
When I run it again, it didn't work.

I tried to do what I did on the first time, adding the read/write trace, but it show it as gray. I ran Clear trace but it didn't help:
enter image description here

1 Answer 1


I needed to put the cursor within the disassembly view (not HEX view), right-click on the disassembly view and then check the option again, it should be available.

This answer help me.

Another thing,
You can't trace if the instruction has breakpoint. You need to remove the breakpoint and then assign the trace.

If you set a function to be traced, and it doesn't print anything, put the cursor on the desired function, on the menu press Debugger -> Tracing -> Function tracing. Try again.

You can view all the traces in the breakpoint window by pressing Ctrl+Alt+B.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.