1

I have a running IDA debug-server on my virtual android device(check attachments). The problem is: when I try hit Attach procces it gives me an error(check title). Here is some kinda params that I'm using: enter image description here

enter image description here

enter image description here

enter image description here

I have already seen similliar question here: Failed to use IDA to remote android debug As @0xC0000022L said: You need to select Remote Linux in the debugger attach menu of IDA, but I don't have this particular option. Is there any ideas? I appreciate any help. Thank you!

1
  • Check the hostname in Process options. Should be the IP of the virtual android device. Another way is to adb port forward port 23946 from the PC to the virtual device.
    – 0xec
    Apr 21 at 21:11
1

See your emulator, your ADB communication probably failed, open your terminal and check that your emulator is displayed with an ADB device, generate a new RSA certificate and try again, I recently had the same problem with debugger from IDA and its competitor JEB, and that was the solution that worked for me.

See also how to properly configure the ADB for your IDA or emulator / device.

Try to allow local connections via adb using:

"adb forward tcp:23946 tcp:23946". This will allow connections to localhost:23946 and forward those to the emulator.

2
  • 1
    Pay attention to the emulator that is using some like NOX usually use a differently configured ADB, if using a physical device is much better, and in the same way check the RSA generated for the connection, please consider a reading time for that article.
    – 0x0A
    Apr 20 at 16:13
  • 1
    That actually worked! Thank you, pal. Apr 20 at 17:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.