0

Unzipped the ghidra application. When I run the .bat file I get the following message

LaunchSupport expected 2 to 4 arguments but got 1
LaunchSupport expected 2 to 4 arguments but got 1
LaunchSupport expected 2 to 4 arguments but got 1

Failed to find a supported JDK. Please refer to the Ghidra Installation Guide's Troubleshooting section. Press any key to continue . . .

Even though the JDK is installed and I have set the path too in environment variables.
What could be the reason for this ?

4
  • What JDK versions (and from which provider/distributor) do you have installed? Check the output of java -version. – Robert Apr 9 at 14:33
  • this needs more information. can you show us java version as @Robert suggested and also your path variables and also from where you downloaded ghidra? – R4444 Apr 9 at 14:50
  • Hi, I got it working. Some configuration issue only. I reinstalled JDK and JRE and included them in environment variables. Is there any alternative to putting things in the path of environment variables or it's always required. I think such a thing is not there for linux. Manually going and specifying some path etc... – Amit wadhwa Apr 9 at 16:48
  • Environment variables always need to be set, regardless of OS. ghidra-sre.org/InstallationGuide.html#JavaNotes – hairlessbear Apr 11 at 10:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.