0

I am working on Mad Max game [ APEX engine ] I do my best to explain the situation.

so my target executes function like this: there are commands like " call [eax+XX] " or " call RX " and these execute all functions. I was able to find some functions by referenced string but this particular function, I just can't, any name I guess ends up wrong.

I want to unlock upgrades. I tried Cheat Engine's Ultimap and found nothing ( except the saving function which saves when a different addon/upgrade is selected ). it seems the checking function is run constantly maybe with different arguments.

so as the calling routine is like this I cant trace back. it's so confusing. there was another game by this engine ( Just Cause 4 ) where I could trace back a string like " X is locked" and reach the deciding code but this one is just driving me crazy.

I think the game uses Vtable but can't find it (i think even if I do, I need leaked SDK and symbols to recognize functions) I tried the IDA pro 7.5+ plugins with no luck.

there are also strings like " bla-bla\bla-bla\XXX_unlock_condition.gsr" and i don't know if they are packed within exe (denuvo protected) or packed within .arc and .tab files. and if it's possible to dump them.

4
  • It sure is allowed to name your RCE target.
    – 0xC0000022L
    Jan 30 at 0:01
  • @0xC0000022L thanks
    – shetal
    Jan 30 at 4:04
  • But what is the question? If it's called like [eax+XX] then there is high probability that it's virtual function, and no, you don't need symbols to push this work further. It's all about your RE skills
    – morsisko
    Jan 31 at 20:44
  • @morsisko well, the question here is i need some help as i lack the experience you are referring to. every tool i use is not working to get the Vtable.
    – shetal
    Feb 1 at 11:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.