0

I managed to deobfuscated the apk Now i have modified some of the source code using Jadx-gui and exporting the project as gradle build

Now when i build the project to run the app in my android emulator It started to give me a whole bunch of errors but i solved most of it. But now the last error i was unable to solve was it was showing no such parent resource could be found Base.xx.xx.. Is there anyway to solve this i tried all solutions from internet but they didn't work... Or are there any simple way to rebuild the whole apk again?

1
  • 1
    If you want to decompile an app and later recompile it don't use Jadx. Use apktool. It has the disadvantage that id decompiles only to Smali instead of Java but apktool is optimized for modifying APKs. Jadx project decompilation only works for small and simple projects or if you are really lucky. Of course you can also try to fix all that errors manually. Or try to decompile the resources using apktool and merge them into the Jadx decompiled project.
    – Robert
    Jan 25 at 11:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.