0

I've download recaf jar file and install JDK 8. When I execute it/start it, it all works fine with java -jar recaf-2.12.0-J8-jar-with-dependencies.jar. I open a class file also no problem. The issue is when I try to edit it is disabled saying:

// =============================================== //
// Recompile disabled. Please run Recaf with a JDK //
// =============================================== //

// Decompiled with: CFR 0.150
...

Any idea why and how to solve this issue? This is my first time using recaf as well so it might be a newbie question.

  • Please do not report Recaf bugs outside of the GitHub issues pages. Most of the time I won't see them: github.com/Col-E/Recaf/issues Also I believe this can be resolved by reading the doc pages: coley.software/Recaf/doc-setup-8.html – Col-E Nov 19 at 19:19
  • Like I mentioned in the issues on the the page I wasn't sure if it was a bug or not so also asked here to see if anyone else has had similar issues with solutions they found – Marco Fernandes Nov 20 at 8:35
0

A few things:

  1. It is best if you report Recaf issues on the Recaf github page, not a 3rd party platform

  2. You can still edit but the recompilation feature is disabled due to the inability to find the local Java compiler. Most of Recaf is based on the assembler, which you can find documentation on here: "Class editing modes"

  3. This problem may still persist after a basic installation of Java 8 because the required platform tools are not added to the classpath. There is documentation on what files are required, where they are, and where you need to place them here: "Java 8 setup"

  4. Alternatively you can update to Java 11 or higher where none of this configuration is necessary.

| improve this answer | |
  • Tried 1-3 and didn't work. Point 4 helped thank you. I literally gave up on it for a bit. – Marco Fernandes Nov 20 at 8:36
  • @MarcoFernandes if you opened an issue on GitHub why you didn’t link to it? – Igor Skochinsky Nov 20 at 17:52
  • @IgorSkochinsky I did it after posting it here first – Marco Fernandes Nov 20 at 19:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.