0

I am using remote debugging with IDA. The target and host machine are Windows.
I can run the process on the remote machine and debug it with IDA using remote debugging but I need that the process will run with high privileges.
In IDA I only have the option start the process (F9 or the green play button) but it doesn't run it with high privileges.

How can I do it?

I searched also in the options of the debugger and didn't see such option.

1

Run the debug server as admin, this should be enough.

1
  • Yes, but I still have weird behaviour. I checked on Procmon and when I run it with privileges local on the system it call RegSetValue for some keys while with the remove debugging it doesn't happen although now it runs with High integrity. Oh, maybe it identify when I use the debugger.. I will need to check it. – E235 Oct 5 '20 at 14:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.