3

I've been trying to extract a Bluetooth door lock's firmware. When I tried extracting it, I got an empty output.

enter image description here

I then found a post which I thought would help me but when I tried using binvis.io, this is what I got:

enter image description here

I'm a newbie so that means it's empty right?

So my question is, what could've cause this to happened? Because when I extract it from a nRf51 chip using OpenOCD and ST-Link V2, it does show that what I extracted is 256kB.

My guess right now is that it is encrypted? Or could it be because im using Windows to execute this? If so, I can try using Kali Linux since I run dual boot. Or maybe I did something wrong when extracting the bin file with OpenOCD? Below is the command used.

dump_image stock_nrf51.bin 0x0 0x40000

Sorry if I sound silly. Newbie here. Please let me know if I'm not being specific enough or not providing enough information. Would gladly provide them if you need them such as bin file etc.

  • what does hex dump show? is it all zeroes? – Igor Skochinsky Jan 4 at 13:10
  • binwalk -E failed because you don’t have matplotlib installed – julian Jan 5 at 16:48
  • @IgorSkochinsky yeah, all zeroes. Any idea? – Calvin9 Jan 7 at 1:16
  • @julian but even if I installed matplotlib installed, I still wouldn't be able to extract it since it shows nothing right? – Calvin9 Jan 7 at 1:16
  • 2
    It’s not encrypted. All zeros means you have no data and the firmware dump was not successful – julian Jan 7 at 1:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.