0

I am not a reverser or a programmer, but I suspect to have a bios rootkit on my ASUS laptop. I want to reflash it with the original firmware from ASUS' site.

The currently installed version is the latest, so if I try to flash it with the same version it won't let me. I tried to modify the date written inside the binary by adding a day, and now the EZflash tool sees it as a new version. But if I try to flash it says that the binary is not valid.

I guess that there is some checking code maybe at the end of the binary. (but I haven't changed the version 303)

Can anyone help me?

You can download the binary here.

  • This doesn't answer your question, but an easier route may be just hooking up to the flash chip with a SPI flash programmer and doing it externally. Take a backup first though. It's also very unlikely you have a rootkit in the firmware of your laptop. What makes you think that you do? – Avery3R Nov 18 at 21:20
  • Your question is very common, but I think it's a very limitated question because concern my private life, for example there are some guys that they know what site I've surfed yesterday. And those coincidences succeeded every days. In the past I have changed 10 dvd burner in few months because they had broken. Then I stopped to buy dvd burner. And those damages suceeded for diffente laptop, for different pc, for different vendor burner. Believe me I know what I'm talking about. But if u want more "physical" evidence I can say you that my ssh key was been stolen. I found two ssh connections. – BiosRootKit Nov 18 at 23:14
  • to my vps from a tor exit node. The ssh server was listening on a non standard port. My current os was openbsd. In many cases I found my webmail not disconnected even if clicked on "logout" button. – BiosRootKit Nov 18 at 23:20
  • I wonder, what attempts to remove the malware have you made prior to resorting to BIOS reflashing? Have you tried wiping out the disk and reinstalling the OS and recovering non-OS stuff from backup? – Michael Kruglos Nov 26 at 22:01
  • Yes ofcourse, i have reinstalled ubuntu many times and once I installed OpenBSD now I am trying to install Windows to backup the bios and reflash from windows but I’m finding many problems to install. I have also boot from freedos to backup the bios with the ami dos tools but it says “write protection” error also just to read. – BiosRootKit Nov 30 at 12:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.