0

I am working on modifying my Intel Pin based tool. As before I am using VS2015 on Windows 10. Previously, I have been testing a tool on the same system where I build it and it worked just fine. The real use of a tool was on the Win7 virtual machine. Recently, I started getting incorrect behavior of a tool. It doesn't crash, however, it stops recording traces before it should and writes the following in the log file:

A:  source\pin\pin\image.cpp: LEVEL_PINCLIENT::RTN_Name: 2012: assertion failed: RTN_Valid(x)

I thought that it was caused by recent updates of a Windows or new antivirus that was introduced by our IT department. However, I tested it on the Win7 VM and it worked there as fine as before. Then I have created Win10 VM without antivirus and switched off all possible security features but got the same assertion failed problem. I have been using Intel Pin 3.6, so I decided to build my tool under 3.11 but got the same problems.

Finally, a question: what causes such behavior?

I know, that Pin's FAQ doesn't explicitly say (https://software.intel.com/en-us/articles/pin-a-binary-instrumentation-tool-faq) that Intel Pin should work on Win10, however it worked for me before.

  • can you post your code? – R4444 Nov 11 at 4:55
  • @R4444 , unfortunately I cannot share the whole source code now, but I can assure that I don't use RTN_Valid in my tool. – aGGeRReS Nov 11 at 8:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.