3

First my setup: Linux Mint 64bit 4.15.0-20-generic

radare2 the newest version from github

/etc/sysctl.d/10-ptrace.conf = 0

Executable: ELF 64-bit LSB executable, x86-64

read write and executable, i can run it with gdb or execute it from terminal

Name = crackme01

What ive done as root:

i verified with ps -ef | grep gdb ps -ef | grep ptrace ps -ef | grep r2 that only my single r2 is trying to attach. then:

1. r2 -d crackme01 2. doo

The error i am getting:

ptrace (PT_ATTACH): Operation not permitted

I found other questions from people with the same problem, but none of their solutions could solve my problem. I would really appreciate it, if someone could help me.

3

This error message probably should be ignored. I found something on the radare2 github

"These ptrace (PT_ATTACH): Operation not permitted messages seem to happen because of subsequent PT_ATTACH calls to the same pid, even though it is already attached. This should be fixed, but it probably shouldn't cause any major issues right now." ~thestr4ng3r

In my case i also did some mistake with radare2 (i forgot to analyse aaa), thats the reason it "didnt work". I ignored this message, proceeded and solved this beginner crackme.

  • 1
    Great to see that you have solved your problem. You can now mark this answer as accepted, so that others can see the problem has been solved. – bart1e Aug 4 at 17:31
  • i must wait until tomorrow to do that, but i will. – Michael Santos Aug 4 at 17:33
  • still 1 hour until i can set this as the accepted answer, 2 days ago it said i need to wait 1 day – Michael Santos Aug 5 at 22:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.