Why is the frida command not available on the command line. After I install Frida by running

$ pip install --user frida

It looks like the installation was successful, but when I run the frida command the system cannot find it.

$ frida
frida: command not found

Is the Python PIP package for Frida broken?

3 Answers 3


Frida was split into two PIP packages.

The package frida only contains the python bindings, while frida-tools also contains the familiar command line tools from earlier releases.
This is explained in the news post for the 12.0 release:

CLI tools

One thing that caused a bit of confusion in the past was the fact that our Python bindings also came with some CLI tools. Frida is a toolkit for building tools, and even though we provide a few sample tools it should be up to you if you want to have them installed.

Up until now this meant anyone building a tool using our Python bindings would end up depending on colorama, prompt-toolkit, and pygments, because our CLI tools happen to depend on those.

Well, that changes now. If you do:

$ pip install frida

You will now only get our Python bindings. Nothing more. And this package has zero dependencies.

The CLI tools might still be useful to you, though, so to install those do:

$ pip install frida-tools


This might be occuring because you are having a multiple users on your device and the frida binary is loaded onto the other users. Same thing happened to me. If you do locate frida

locate frida

you will possibly find out that frida is installed on the other user bin directory.

  • 2
    This is not the behavior of pip; it will install to the current user's home directory. Commented Feb 7, 2021 at 18:47

install frida-tools

pip install frida-tools

After this frida will work fine. Worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.