0

I have unpacked a firmware binary using binwalk and have identified the architecture as MIPS by running file bin/busybox . When I try to run the binary with the proper static version of qemu, i get an error with FPU mode ex:

 chroot . ./qemu-mips-static bin/busybox
 qemu: Unexpected FPU mode 

I can't find anything on this error. I have tried this on several different firmwares and i keep getting the same error.

The OS is Kali linux with qemu-user-static installed and the qemu-mips-static static binary place in the root directory of the unpacked firmware.

0

According to the source code, the EABI from your ELF is not compatible. It seems to be specific to MIPS, you can find the structure here, this structure is stored inside a specific ELF segment, the code in charge to read it is here. I suggest you to make sure this segment is present and if it contains correct values. I think you can dump this information with readelf(1).

  • How do I indentify the proper segment in readelf? what am I looking for? – Lexicon Mar 22 at 20:52
0

This could be a bug of qemu. I had a similar issue and managed to resolve it by recompiling qemu with the patch suggested in qemu mailing list

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.