1

I'm trying to decompile the LUCs (customly extensioned LUAs) from both of the games but they won't decompile, they aren't encrypted and use LUA version 5.0.2 (32-bit) according to the game's code. They are headered LuaV with extra bytes of some sort. Anyone willing to help me decompile these files? If so thanks so much.

https://zenhax.com/download/file.php?id=6262 (Vol 1)

https://zenhax.com/download/file.php?id=6251 (Vol 2)

  • I'd compile that version of lua and find the simplest file that can be hand-decompiled, or if the game still has the lua decompilation functions I'd use those to compile some simple code. Then i'd recompile it in the normal version of lua and look at what the differences are. – Avery3R Mar 11 at 19:09
  • The game doesn't mention LUC in the executable code but still reads from them (I'm likely missing a library of some sort), it also loads LUA extensioned files similarly this way. I did compile a simple testing LUA of my own and use luac -l on a LUC after fixing some header bytes while using my LUA as an idea and I always get error of some sort. The smallest file I know is Hippogriff, I'm trying to decompile that one for an example on decompiling the other files. One of the games have a few plain LUA files but are missing characters yet the game still reads them fine. – LolHacksRule Mar 11 at 21:54
  • Anyone going to get back to this? I decided to return to this for more documentation on the game code, but this is still hard to mess with, I tried unluac after the changing header but unluac still refuses to decompile it no matter what I try, WordMasterData in Vol2 is the smallest file. – LolHacksRule Sep 1 at 2:40
  • The way that I would recommend you move forward is to bindiff the game's binaries with a version of lua that you compiled, then look at the differences in the functions relating to creating or parsing compiled lua files. – Avery3R Sep 16 at 21:55
  • There's a mechanism where Lua files in scripts/common get compiled to Luc files if they aren't already present, I tried my own and I decompiled it fine after fixing bytes with ChunkSpy to help me on it. cdn.discordapp.com/attachments/391399338040885249/… cdn.discordapp.com/attachments/391399338040885249/… cdn.discordapp.com/attachments/391399338040885249/… – LolHacksRule Sep 18 at 20:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.