I need help identifying a chip and how to reset it from a new Brother's toner cartridge TN227 and TN223. This comes from the new Brother HL-L3230CDW laser printer.

There is currently no information on how to reverse engineer these chips to reset them, so I decided to investigate further, however I'm currently stuck.

Here are some pictures of the starter TN223 chip that my printer came with:

Pads of chip with numbers I added

Back of Chip

Light shining through chip

The pictures are shown as following:

  • Pads of chip with numbers I added
  • Back of Chip
  • Light shining through chip

I then opened the printer to determine which pins go to what. I first used a multi-meter to determine that pads 2,3,4 are shorted to each other on each chip for each color C, Y, M, BK. I then found pad 2 was shorted to the printer frame, so I assumed that was ground. Then I looked at the wiring color. It's matched as the following:

  • 1: purple, 2: white, 3: black, 4: red

When I attempted to measure any voltages from any of the pads during power-on, I was unable to measure anything.

I then connected a logic analyzer to the printer with the chip attached to see if I could figure out what protocol it was using. Assuming white is GND, Here's a sample of the Sigrok Pulseview received:

sample data assuming pad 2 is ground

zoomed in on start of data

I ran the test twice and attached the Sigrok file results here and here.

These can be opened in Pulseview (free program) for a graphical representation of the data

It appears that the data is only sending when pad 4 goes high, I assume this is VCC. I then measured the voltage from pad 4 when communication occurs using an arduino and measured 3.3V. I now assume the chip is using 3.3V logic.

I still don't know if the pad 2 is GND since pad 3 is black which usually indicated ground, however as previously stated pad 2 is shorted to the frame of the printer. I then attempted to connect pad 3 as GND to my logic analyzer and connect pad 2 as not ground, however something strange occurred, and the printer no longer accepted the cartridge I was messing around with. Going back to pad 2 as ground, and it started working again. I'm now assuming pad 2 is ground.

When investigating the data further, there seems to be a little difference between two runs. I simply turned the printer on and recorded data then immediately turned it off then back on to get my second run, however the data seemed to change slightly. To ensure it wasn't due to sampling error, I increased the sampling to 20 MHz, which includes about 20 samples per clock cycle which should be sufficient to measure the wave forms consistently. When measuring the clock rate, I found it to be between 432-457Khz.

One idea I currently have is to analyze the data and find the ASCII text "brother" since each chip is required to have a manufacturing name and because the cartridges I have are from brother. More info can be found in Brothers white paper.

I'm not sure the best approach to analyze the binary data, since I can't identify the communication protocol, and I'm concerned that it might be encrypted. After searching patents to see if I could find more info on the chip, this was all I could find: http://www.freepatentsonline.com/y2013/0070279.html This suggests that the chip may be using crypto to hide info on the chip. If so, would it possible to crack it?

I tried analyzing the data as if it were I2C, but this doesn't seem right, Also I'm pretty sure it's not SPI. I do know there's a clock involved, so I know it has to be synchronous, but any help would be appreciated!

  • 1
    I'm guessing it's I2C and D3 is SCL, D1 SDA, and D4 VCC
    – Avery3R
    Commented Mar 7, 2019 at 2:56
  • The issue I have with I2C is that my data line is normally low as compared to normal I2C which is normally high, also I can't identify a start condition since both the clock and data line go high at the same time. I added an image showing the start of the data above.
    – benjinne
    Commented Apr 4, 2019 at 12:54
  • Do you have any update? Thanks, Akos Commented Sep 6, 2019 at 18:47
  • No, haven't messed with the printer since I posted this. Let me know if you find anything @AkosFazekas. Thanks
    – benjinne
    Commented Sep 8, 2019 at 14:33
  • Can you post the binary messages as a hex dump? Commented Dec 28, 2019 at 12:04

1 Answer 1


If you have a Brother printer you can use these instructions I found on Amazon on how to reset your cartridge chip, it worked for me.

"I was able to reset my toner cartridges for this model by using the process that I found by doing some googling for a "better way to reset brother" toner cartridges.

Summarized, open the inside cover where the toner cartridges are located. Next, press the back and X buttons simultaneously. Then, press the back button again. This should bring up the toner reset menu.

I had to try a number of times...I think I wasn't pressing exactly at the same time on those two buttons OR they intentionally build it so you have to do it multiple times to make it work. In any case, it is now reset. Happy Camper."

  • The latest firmware, MAIN:1.35, SUB1:1.14, SUB5:1.00 will not allow me to reset the toner cartridges. Commented Jan 18 at 16:14

Not the answer you're looking for? Browse other questions tagged or ask your own question.