-1

I am new with IDA assembler and i used to work with hopper app. the problem is i can't change instruction in IDA from something like CBNZ to NOP. is there any button to do this? i can't find anything on the internet and I have been searching for it all day. I have tried many options from the edit menu.

New contributor
jimuty is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
  • 1
    Have you tried this ? – shxdow Jan 12 at 20:35
  • @Biswapriyo never understood that kind of advice, so since you repeated it, let me ask: why not change this to an unconditional jump? Why just invert the jump condition? – 0xC0000022L Jan 14 at 9:43
2

NOTE: I'm assuming you're using IDA 7.X, although this should work equally well for 6.X versions.

The option you're looking for is called Patch Program. For your specific question, you'd do the following:

  1. Select the instruction you want to change
  2. Go to Edit -> Patch Program -> Assemble
  3. Replace the instruction in the text box with the instruction you'd like it to be.
  4. Click OK

The original instruction will now have been replaced with the new one.

This article has more info and examples of using the other options in the Patch Program submenu.

New contributor
hairlessbear is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
  • thank you for your answer. I have tried that before. the program says: sorry, this processor module doesn't support the assembler, I am trying to patch an ios arm7 app. – jimuty Jan 13 at 5:36
  • 1
    Are you using the free version? If you are, this might be a side effect of that. It's also possible that the error message is accurate and that feature really isn't available for iOS binaries; I'm not sure. Regardless, here are two examples of people using alternative methods to patch iOS binaries; maybe one of them will help. zdziarski.com/blog/?p=2172 resources.infosecinstitute.com/… – hairlessbear Jan 13 at 7:33

Your Answer

jimuty is a new contributor. Be nice, and check out our Code of Conduct.

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.