I have a floppy disk image which I am trying to load with Bochs Emulator.

It is from a CTF challenge and can be downloaded from here: http://squarectf.com/2017/floppy.img

I am using Bochs version 2.3.9 on Windows 7 x64

I started Bochs.exe and configured the memory and disk settings as shown below:

Memory options:

enter image description here

Disk and Boot options:

enter image description here

However, when I start the emulator, it gives the following error:

enter image description here

I have seen a writeup online for this CTF that describes the same method for loading the disk image and it worked.

Please let me know why it does not work for me.

Note: I am able to load the disk image using qemu-system-x86_64 or qemu-system-i386 on Linux already. However, I want to understand why I cannot load it with Bochs.

I even tried the method of creating a bochsrc file and loading it using bochsdbg.exe as shown below:

bochsdbg.exe -f bochsrc -q

However, I still get an error while loading it.

Update: I am able to load the image in Bochs emulator by selecting floppy as the boot device under Boot options.

However, I cannot load the image using bochsdbg.exe. Below is my bochsrc.txt file:

romimage: file=$BXSHARE/BIOS-bochs-latest
vgaromimage: file=$BXSHARE/VGABIOS-lgpl-latest
megs: 16
ata0: enabled=1, ioaddr1=0x1f0, ioaddr2=0x3f0, irq=14
ata0-master: type=disk, path="floppy.img", mode=flat, cylinders=2, heads=16, spt=63
boot: floppy

And I get the following error message:

Bochs is exiting with the following message:
[      ] bochsrc.txt:5: ataX-master/slave: unknown type 'floppy'

The reason I want to have a proper bochsrc file is because I want to use IDA Pro to debug the boot sector.

  • 2
    Looks like its trying to boot from the Hard Drive. Check the boot options in bochs. This image.
    – 0xec
    Nov 3, 2018 at 5:43
  • @0xec Thanks. I am able to load the image in Bochs emulator now. I selected floppy as the boot option. Now, I have another question. While I am able to get it working using the Bochs GUI, I still cannot get it to load properly using bochsdbg.exe. I have updated my question with my bochsrc file. Please have a look and let me know if it works for you.
    – Neon Flash
    Nov 3, 2018 at 13:24
  • 3
    Your bochsrc is incorrect. ata is for the hard disk. Should rather be floppya. Have a look here under Section 4.3.19. floppya/floppyb
    – 0xec
    Nov 3, 2018 at 17:39

1 Answer 1


I fought a similar error for a while and figured I was naming the disk image as disk.img. When I renamed it to something else, it worked. In your example, you're naming it to floppy.img, so you could try something else.

It's a bit of a guess, but seems like bochs doesn't like files with reserved words, like disk or floppy.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.