0

I downloaded radare 2.5 for windows. I am trying to debug a binary on windows with radare and have tried the following:

radare2 -d a.exe
fork_and_ptraceme/CreateProcess: The request is not supported.
w32_dbg_maps/w32_OpenProcess: The parameter is incorrect.
[w] Cannot open 'dbg://a.exe' for writing.

I also tried to use gdbserver and use radare to connect remotely. It connects but it gets stuck and I am not able to give it any commands or see anything.

I am going to try windbg remote as well, however, I am starting to wonder, do I need to install another set of libraries or another type of debugger, or do some additional configuration to make debugging work with radare2. Any suggestions?

  • 1
    Do you use a 32-bit or a 64-bit machine? Is the executable you are trying to debug is 32bit or 64bit? – Megabeets May 2 '18 at 14:15
  • @Megabeets I was using 32 bit version, it turns out. Switched to 64bit and things are looking peachy. – Vitaly Omelchenko May 2 '18 at 16:56
  • Yup. That's what I thought. It's a bitness problem – Megabeets May 2 '18 at 16:58
3

You are most probably using radare2 version downloaded by following the link on the official website (http://radare.mikelloc.com/get/2.5.0/radare2_installer-msvc_32-2.5.0.exe). The link is to the 32-bit application, but you need to open the directory and download the 64-bit radare2 version. Just encountered this issue myself.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.