So, I have this problem: I'm trying to do a homework which, at one point, asks us to use IDA to debug a simple program step by step. The deal is, when I load the executable in IDA, the Debugger option in the menu suddenly dissapears.

What exactly is happening, or what am I doing wrong?

  • Please tell a bit more about your executable and environment. OS ? Processor ? In which OS are you running IDA ?
    – w s
    Commented Apr 24, 2018 at 14:50
  • WIndows XP in a Virtual Machine. Processor, AMD Phenom II X6 1055T I think... Commented Apr 24, 2018 at 15:07
  • And what about executable you’re trying to debug ?
    – w s
    Commented Apr 24, 2018 at 15:08
  • An .exe with simple code: #include <stdio.h> int main() { //Este programa realiza la suma simple de dos números enteros printf("Sumando dos enteros\n"); int suma = 2 + 3; printf("%i",suma); return 0; } Commented Apr 24, 2018 at 15:09

1 Answer 1


You are not specifying what IDA version you are using and if at all you are trying to run the code that could be debugged by IDA on the machine that you are running it, but there might be another case.

Chris Eagle in this The IDA Pro Book writes...

IDA attempts to warn you of this possibility anytime you select Debugger → Start Process (or Debugger → Attach to process with an open database) by displaying a debugger warning message stating the following:

You are going to launch the debugger. Debugging a program means that its code will be executed on your system. Be careful with malicious programs, viruses and trojans!

REMARK: if you select ‘No’, the debugger will be automatically disabled. Are you sure you want to continue?

Selecting No in response to this warning causes the Debugger menu to be removed from the IDA menu bar. The Debugger menu will not be restored until you close the active database.

So maybe at one point you've answered no and IDA remembers this in the database? Try new analysis from scratch to see if the menu gets restored.

  • Is the 4.9 version. And I don't open the project doing neither of those options (Doesn't even shows the Star Process one). The project doesn't want to open win the VM, it says that there is an instruction that isn't allowed. I made the executable in Lubuntu, where it worked fine. Commented Apr 24, 2018 at 17:28
  • 1
    you made it in lububtu with gcc so it is elf ? and you are trying to debug it in windows ?? which is PE no that wont work
    – blabb
    Commented Apr 24, 2018 at 18:18
  • Then how I am suposed to do it? Because in theory, gcc was supossed to work (As it is what the project said) Commented Apr 24, 2018 at 19:17
  • @TheFerydra compile under windows, to create PE, or, I think, use remote debugging that IDA should support (but not sure if 4.9 does that) Commented Apr 24, 2018 at 19:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.