20

In all versions of IDA, I can't seem to be able to search for unicode strings. When reversing programs, I constantly see unicode strings that could have really helped if I could see them in the strings window, but I can't. Anyone have a solution?

1 Answer 1

23

Enter the "strings window" by either press shift+F12 or go to View > Open Subviews > Strings in the toolbar.

Then, in the strings window, press Right Click and choose "Setup...". Check "Unicode" and press "OK".

enter image description here

3
  • 4
    I can't believe I didn't know this until now, thanks in advance!
    – user24091
    Apr 20, 2018 at 5:59
  • 2
    There is a registry change during this selection HKCU\Software\Hex-Rays\StrWinStringTypes -- REG_BINARY -- 00 01 02
    – Biswapriyo
    Apr 20, 2018 at 15:50
  • Exactly what I was looking for. Thank you!
    – ra170
    Oct 4, 2023 at 15:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.