0

Hey I was using Windasm32 today and I loaded a .dll file and it told me this

enter image description here

I tried to increase my virtual memory on windows 10 to 12000 and the max to 12000 and restarted the computer and ran the windasm32 in admin and it still gave me this error. So, how can I fix this?

  • 1
    do you really need to use the tool that is still mentioning Win 3.1? Why W32dasm and not some new one? – Paweł Łukasik Mar 25 '18 at 5:29
  • Because it has a more better way to show all string data references so I can find the text strings easier others like olydbg does not have this option it seems that I can find string references on windasm32 better than I can find them on ollydbg , ollydbg does not show some strings like windasm32 so yeah are you going to help me out on this issue of mine or ? – John Nay Mar 25 '18 at 5:42
  • I am running Windows 10 not windows 3.1 – John Nay Mar 25 '18 at 5:47
  • 1
    omg this stopped working correctly since windows 2000 that's almost a quarter century back please get yourself familiarized with new tools most the new rookies on the block weren't even born then and wouldn't even know what this dinosaur is or was – blabb Mar 25 '18 at 6:08
  • Well how do I find string data references in IDA Pro – John Nay Mar 25 '18 at 6:11
2

Windasm32 is a very old 32-bit program and is probably running out of the 2GB virtual memory space allocated for it by Windows (you should be able to confirm it using a tool such as VMMap). One possible workaround could be to set the IMAGE_FILE_LARGE_ADDRESS_AWARE flag in the PE Header which would give it an additional 1GB of address space, e.g using editbin:

editbin /LARGEADDRESSAWARE  windasm32.exe

However this may lead to bugs and/or crashes if the program is not prepared to handle addresses above 0x80000000. And it may still not be enough for the program you're trying to disassemble.

I would strongly suggest using another, more modern disassembler instead that can handle big files. If you can't find the functionality you need, ask a new question about it.

| improve this answer | |
2

Try this. In the menu, click:

Disassembler -> Disassembler Options -> Enable extended memory

Source (first post, translated to English)

W32Dasm893 Fix

  1. Removed the restriction of the disassembler to the number of lines of code that leads to messages: "W32Dasm could only allocate enough memory to process XXXXXX lines of Text ..."
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.