1

I'm using BinDiff to perform diff operation between two 32-bit Binaries (one of them is a DLL and the other one an EXE).

When I perform the Diff Operation, I get the error message:

Adding new Diff to workspace failed. Diff binary does not exist.

I am using IDA Pro version 6.9.160222 and BinDiff version 4.2.0

I opened each of the binaries with IDA Pro and saved the IDB file. BinDiff was launched using bindiff.cmd (which in turn launches the bindiff.jar)

From the GUI, I created a New Work Space and then from the menu, Diffs -> New Diff

For the Primary and Secondary source, I selected the IDB files corresponding to each of the binaries. Now, when I press Diff, it gives the error message: "Adding new Diff to workspace failed. Diff binary does not exist."

Why is it not able to locate the Diff Binary?

Both differ.exe and differ64.exe are present in the same directory as bindiff.jar

Another option I tried was in IDA Pro, instead of saving the IDA, I used the BinExport plugin to save the BinExport Files. Even when BinDiff uses the BinExport files saved from IDA Pro, I get the same error message.

My OS Version is: Win 7 64-bit.

  • 1
    As an alternative, you might consider using Diaphora instead of BinDiff if it doesn't work at all for a reason. – joxeankoret Oct 22 '17 at 11:24
  • 1
    @joxeankoret: you should really plug Diaphora more often. Great tool. Thanks for creating and maintaining it. – 0xC0000022L Jun 19 '18 at 12:07
1

I think there is a problem with BinExport.

When I used BinNavi, there was similar problem. BinExport was not compatible with my IDA version.

The IDB file structure differs for each version of IDA. Access the following URL and Check which version of IDA is supported by BinExport.

https://github.com/google/binexport

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.