1

I am trying to get radare2 to "run" on my windows7 64-bit system.

I downloaded the radare2-1.5.0.zip file from http://radare.org, but when I unzip it and try to run any of the tools, I simply get "there is a problem with this program and it must be closed".

Is it possibly because these were compiled for x86 not x64 operating system?

  • I have similar issue - try report an issue in their GitHub repo? – Paweł Łukasik Jun 1 '17 at 7:29
  • Same occurs for me on Windows 10 – fpmurphy Jun 2 '17 at 3:48
  • @fpmurphy1 why not run radare2 Linux binary under Windows Subsystem for Linux (WSL/LXSS), it work without any problem under Windows 10 for me. – adrián Jun 29 '17 at 12:04
4

Use the binaries built with MSVC http://radare.mikelloc.com/get/2.3.0/radare2_installer-msvc_32-2.3.0.exe or this one http://radare.mikelloc.com/get/2.3.0/radare2_installer-msvc_64-2.3.0.exe

1
  1. Go to https://github.com/radare/radare2/releases
  2. Click on the link after "Builds:", e.g. http://radare.mikelloc.com/get/2.3.0/
  3. Download installer, e.g. radare2_installer-msvc_64-2.3.0.exe
  4. Run installer
  5. Run path\to\your\home_dir\AppData\Local\Programs\radare2\radare2.exe
0

The version 1.5.0 built with mingw32 is not working, try to use 1.4.0 instead until 1.6.0 is released here or download the msvc build here.

0

I had the same issue and was solved using the x64 version. Just download http://radare.mikelloc.com/get/1.5.0/radare2-w64-1.5.0.zip and give it a try.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.