-1

I've reverse engineered quite a bit of action cameras based on Allwinner's poorly documented chipset.

It runs firmware closely related to H3, in fact I can compile a kernel that boots with no video from this source: https://github.com/friendlyarm/h3_lichee (using crane-sdv config)

After getting ext2 working I would like to compile v4l utils for this system. This way I can record video with MY parameters using the adb command line.

So my question is how can I do this? I don't have the tiny android source code although it appears based on 4.2.2 sans java. The rootfs is only 20MB but it has the full v4l2 system.

I tried cross compiling with linaro against the /system/lib folder of rootfs but I can't run v4l-ctl, it says file not found.

more info on the fw is here:https://dashcamtalk.com/forum/threads/hacking-q3h-allwinner-v3-camdroid.20507/

What do I try next?

Compiled stuff wasn't running because I had to use the android ndk so it can use the correct linker.

you can proceed to kick the question back out on your technicality boys, thanks for the non-help

  • Your question seems to be more about compiling than reverse engineering – NirIzr Sep 9 '16 at 23:00
  • the other reverse engineering was done already. I binary patched the main application and libs as was documented. – gamut Sep 10 '16 at 19:07
  • Sorry, I pointed that out to suggest other Stack Exchange sites might be a better fit for this type of questions. – NirIzr Sep 10 '16 at 19:57
  • I tried to ask before about getting ext2 working with similar/incomplete kernel tree and they had no clue over in unix. I figured it out myself and how to boot off of SD card fully... just in that case vold won't mount external sd and I can't record. – gamut Sep 10 '16 at 20:09
  • wow, thanks guys for the wonderful help and just kicking my question out because you couldn't answer it. Nice technicality by the way. Compiled stuff wasn't running because I had to use the android ndk so it can use the correct linker. Now I need to figure out how to get around the missing libraries but no point in asking here, I'll just get my question tossed. – gamut Sep 13 '16 at 1:06