0

I had some fun using IDA Pro Dalvik Debugger in the past using AVD emulator. However I stumbled upon a APK that somehow does not run well inside AVD. APK runs fine on a real device so I am trying to use IDA Pro dalvik debugger to debug the APK on a real device.

The problem is, when using AVD all I had to setup was packagename and activity name in the Debugger Setup -> Set specific options and debugger worked well but trying on a real device keep fails with message like ADB error: listener 'tcp:239166' not found or IDA started the application but unable to connect .. message.

I tried adb forward on a port Dalvik debugger is using but no progress :(

Can anyone provide help? Thanks in advance.

  • ADB request: 0000: 30 30 31 32 "0012" ADB request: 0000: 68 6F 73 74 3A 74 72 61 6E 73 70 6F 72 74 2D 61 "host:transport-a" 0010: 6E 79 "ny" ADB answer: 0000: 4F 4B 41 59 "OKAY" ADB request: 0000: 30 30 30 34 "0004" ADB request: 0000: 6A 64 77 70 "jdwp" ADB answer: 0000: 4F 4B 41 59 "OKAY" ADB answer: This repeats in the IDA debug msg – Jaewon Min Aug 3 '16 at 3:28
0

Setting the target app to debuggable in the android manifest and repackaging the apk has done the job. I didn't know that AVD automatically sets the APK to debuggable.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.