8

Has anybody gotten Immunity Debugger to work on windows 10 yet? I downloaded it on Windows 10, launch it as administrator, and the GUI opens for about half a second and then it exits, no errors or messages. I have python installed, I reinstalled immunity multiple times, and I tried running it in Windows 7 compatibility mode. Nothing seems to work. My theory is that some dll is missing or changed. Any ideas or is it just my computer? Also, Ollydbg does work on 10, but I find Immunity debugger more useful.

15

I am running Windows 10 x64 and I had the same problem as you do. The problem is with the environment variables regarding your Python installation. I am using Python 2.7.11 which is the currently latest release for the 2.x series.

So, to make Immunity Debugger work on Windows 10 modify(and ADD if necessary) the following environment variables(assuming Python is installed at C:\Python27):

  • PATH="C:\python27;%PATH%"
  • PYTHONHOME="C:\python27"
  • PYTHONPATH="C:\Python27\DLLs;C:\Python27\Lib;C:\Python27\Lib\site-packages"

The following changes made it work for me.

  • setting PYTHONPATH fixed it for me. thanks! – tintin Jul 4 '16 at 13:09
  • I'm sure I'm being an idiot but can you point me in the direction as to where these variables are? – user16916 Jul 29 '16 at 19:58
  • 1
    On windows 10? Right-click on the Start button and select system, then on the right select advanced options, then at the bottom of the next window select environment variables, then you should be able to edit and add to the PATH variable. I believe its in the bottom section of variables. – Starwarsfan2099 Jul 29 '16 at 20:01
  • Thanks this method worked....Creating new variables other than PATH – user17627 Oct 1 '16 at 16:42
  • This solution made the trick on Windows Vista as well. Got this problem after upgrading python. Adding PYTHONHOME and PYTHONPATH to env variable did the trick. Thanks! – randoms Feb 28 at 8:37

Not the answer you're looking for? Browse other questions tagged or ask your own question.