5

I followed the tutorial IDA Help: Debugging code snippets with QEMU.

It always worked with ARM code, but now I have to reverse some MIPS and only nops are displayed like this:

enter image description here

Should I adjust something on the memory map? As you can see, the code is rebased in the range of 0x8f0000000. Or is it something with the generated intermediate ELF file?

I am using the Mipsel_Malta config, cmd line is

"D:\attila\qemu\bin\qemu-system-mipsel" -S -gdb tcp::%p,ipv4 -cpu 4Km -kernel "%e".

5
  • 1
    Seems like you haven't configured the gdb_arch.cfg properly Commented Feb 26, 2016 at 11:53
  • 1
    techbliss.org/threads/… Commented Feb 26, 2016 at 12:00
  • My gdb_arch.cfg is in fact configured properly and according to the one discussed on the thread you linked, but thank you. Commented Feb 28, 2016 at 13:43
  • 2
    Last month i was reversing my router firmware and i had used this for setting up my MIPS debugging platform digital-forensics.sans.org/community/papers/grem/… Commented Feb 28, 2016 at 14:43
  • 2
    But anyway i will more than happy to look into your code if you are willing. Commented Feb 28, 2016 at 14:46

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.