1

So this is from some "Reversing with Lena" tutorial series on how to start out with reverse engineering and OllyDbg. (Found here https://tuts4you.com/download.php?view.124) It's a bit old but should still work fine I believe.

Part 1 and 2 worked just fine, but when I try to load the Binary of Part 3 into OllyDbg it complains about a corrupt breakpoint and the assembly shown doesn't look like the assembly in the tutorial at all.

When I choose "Select module => RegisterMe" in the context menu it looks like it should. However it still doesn't really run (even when I do "New origin here" it only runs a view lines before the same thing happens. It kind of just does nothing anymore, OllyDbg says "Running", the assembly either goes blank (when I didn't change origin) or shows some RtlAllocateHeap function.

Also there are Access violation errors and exceptions I have to tell it to pass to the program.

The log: http://pastebin.com/mCV7Pkxh My only idea is that maybe BitDefender has something to do with it. But it didn't block anything and tried to turn it off too.

  • Oh, and the application runs just fine when I doubleclick it, so it isn't that it's broken. – Hako Sep 19 '15 at 10:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.