1

I'm working on a Linux x86_64 ELF binary using IDA 6.6.

When I run the Hex-Rays Decompiler on a function (by pressing F5) it always shows me the pseudocode for the _init_proc function, no matter what I run it on. It's stuck on that function and won't show me anything else in the pseudocode view. No errors are displayed or printed to the log.

If I produce the C file (Ctrl+F5) the full pseudocode is generated, so it's just an interface issue.

This is driving me mad. Things I've tried:

  • Restarting IDA
  • Recreating the database
  • Deleting all decompiler information for _init_proc
  • Deleting all decompiler information for the function I'm trying to decompile

Has anyone encountered this behaviour before? Any suggestions?

  • Have you tried reporting this problem to support@hex-rays.com? – Jason Geffner Aug 21 '15 at 1:43
  • @JasonGeffner I was about to report it, then I solved it myself shortly after asking this question. Should have answered immediately but it was 3AM ;) – Andrea Biondo Aug 21 '15 at 9:03
1

Reset IDA configuration

I eventually solved this issue by completely erasing IDA's configuration. I'm on Windows, so I removed the HKCU\Software\Hex-Rays key. On Linux you should probably try removing ~/.idapro/ida.reg.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.