I'm trying to learn Ghidra. Say, if it generated the following code for loading functions from an array of function names from gpfnCommCtrlAPI
:
I was able to retype gpfnCommCtrlAPI
into char*[14]
which made it quite readable:
But then is it possible to retype g_pfnsUxCtrl
, a pointer to an array of function pointers, (possibly with a custom enum
) to make it a little bit more readable? Here's an example of how it looks now in case of g_pfnsUxCtrl[7]
:
PS. To understand what index 7
refers to in that case I need to go back to the gpfnCommCtrlAPI
array, which may not be immediately available where g_pfnsUxCtrl[7]
is used.
PS2. In that case case, I manually renamed p_comctl32_HandleScrollCmd
variable to make it more readable.
comctrl32.dll
x86 build from Win10.